aboutsummaryrefslogtreecommitdiff
path: root/npmPackages/fs.realpath/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'npmPackages/fs.realpath/default.nix')
-rw-r--r--npmPackages/fs.realpath/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/npmPackages/fs.realpath/default.nix b/npmPackages/fs.realpath/default.nix
new file mode 100644
index 0000000..c18b12f
--- /dev/null
+++ b/npmPackages/fs.realpath/default.nix
@@ -0,0 +1,21 @@
+{ fetchurl, buildNpmPackage, tap }:
+
+buildNpmPackage {
+ pname = "fs.realpath";
+ version = "1.0.0";
+ src = fetchurl {
+ url = "https://github.com/isaacs/fs.realpath/archive/v1.0.0.tar.gz";
+ sha256 = "16ybsq9mxm1cwwpx2j3k2pffznsqil13ifkwf6q8q2dpavmsy5k2";
+ };
+
+ meta = {
+ description = "Use node's fs.realpath, but fall back to the JS implementation if the native one fails";
+ homepage = "";
+ license = "ISC";
+ };
+
+ npmInputs = [
+ tap
+ ];
+}
+