aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sproxy2/main.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sproxy2/main.nix')
-rw-r--r--pkgs/sproxy2/main.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/sproxy2/main.nix b/pkgs/sproxy2/main.nix
new file mode 100644
index 0000000..d02fba7
--- /dev/null
+++ b/pkgs/sproxy2/main.nix
@@ -0,0 +1,24 @@
+{ mkDerivation, aeson, base, base64-bytestring, blaze-builder
+, bytestring, cereal, conduit, containers, cookie, docopt, entropy
+, Glob, http-client, http-conduit, http-types
+, interpolatedstring-perl6, network, postgresql-simple
+, resource-pool, SHA, sqlite-simple, stdenv, text, time, unix
+, unordered-containers, wai, wai-conduit, warp, warp-tls, word8
+, yaml
+}:
+mkDerivation {
+ pname = "sproxy2";
+ version = "1.96.0";
+ sha256 = "0wzkh312d7h957vkf2qqsbnf9xm98vm8y5kzray87rn6rdc5k5x6";
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base base64-bytestring blaze-builder bytestring cereal
+ conduit containers cookie docopt entropy Glob http-client
+ http-conduit http-types interpolatedstring-perl6 network
+ postgresql-simple resource-pool SHA sqlite-simple text time unix
+ unordered-containers wai wai-conduit warp warp-tls word8 yaml
+ ];
+ description = "Secure HTTP proxy for authenticating users via OAuth2";
+ license = stdenv.lib.licenses.mit;
+}