aboutsummaryrefslogtreecommitdiff
path: root/pkgs/probes.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/probes.nix')
-rw-r--r--pkgs/probes.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/probes.nix b/pkgs/probes.nix
new file mode 100644
index 0000000..650c996
--- /dev/null
+++ b/pkgs/probes.nix
@@ -0,0 +1,28 @@
+{ stdenv, pkgs, lib }:
+
+let
+ plugins = [
+ "check_disk"
+ "check_file_age"
+ "check_http"
+ "check_load"
+ "check_log"
+ "check_mysql"
+ "check_mysql_query"
+ "check_procs"
+ "check_swap"
+ "check_users"
+ ];
+
+in stdenv.mkDerivation {
+ name = "local-monitoring-plugins";
+ phases = [ "installPhase" ];
+ installPhase = ''
+ mkdir -p $out/bin
+ ${lib.concatMapStringsSep "\n" (p: ''
+ cp -a ${pkgs.monitoringPlugins}/libexec/${p} $out/bin/${p}
+ '') plugins}
+ cp -a '${pkgs.check_mdstat}/bin/'* $out/bin/
+ cp -a '${pkgs.check_systemd}/bin/'* $out/bin/
+ '';
+}