aboutsummaryrefslogtreecommitdiff
path: root/pkgs/mywatch/main.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/mywatch/main.nix')
-rw-r--r--pkgs/mywatch/main.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/mywatch/main.nix b/pkgs/mywatch/main.nix
new file mode 100644
index 0000000..8d78483
--- /dev/null
+++ b/pkgs/mywatch/main.nix
@@ -0,0 +1,21 @@
+{ mkDerivation, aeson, base, bytestring, ConfigFile
+, data-default-class, docopt, fast-logger, filepath, http-types
+, interpolatedstring-perl6, MissingH, mtl, mysql, mysql-simple
+, network, resource-pool, scotty, stdenv, text, unix
+, unordered-containers, wai, wai-extra, wai-middleware-static, warp
+}:
+mkDerivation {
+ pname = "mywatch";
+ version = "0.3.0";
+ sha256 = "1a7fqyn0pvnbxzn9fiaib4pj7hq5p2qgnbdwryg70lkgnjm4y0h4";
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base bytestring ConfigFile data-default-class docopt
+ fast-logger filepath http-types interpolatedstring-perl6 MissingH
+ mtl mysql mysql-simple network resource-pool scotty text unix
+ unordered-containers wai wai-extra wai-middleware-static warp
+ ];
+ description = "Web application to view and kill MySQL queries";
+ license = stdenv.lib.licenses.mit;
+}