aboutsummaryrefslogtreecommitdiff
path: root/pkgs/hoogle/main.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/hoogle/main.nix')
-rw-r--r--pkgs/hoogle/main.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/hoogle/main.nix b/pkgs/hoogle/main.nix
new file mode 100644
index 0000000..9c9a682
--- /dev/null
+++ b/pkgs/hoogle/main.nix
@@ -0,0 +1,28 @@
+{ mkDerivation, aeson, base, binary, bytestring, cmdargs, conduit
+, conduit-extra, connection, containers, deepseq, directory, extra
+, filepath, haskell-src-exts, http-conduit, http-types, js-flot
+, js-jquery, mmap, network, network-uri, old-locale, process
+, process-extras, QuickCheck, resourcet, stdenv, tar
+, template-haskell, text, time, transformers, uniplate, utf8-string
+, vector, wai, wai-logger, warp, warp-tls, zlib
+}:
+mkDerivation {
+ pname = "hoogle";
+ version = "5.0.13";
+ sha256 = "1wxdzkifgm3bnpzr45sf49dyqwnb8bnc5wmqbv5yhxv19gmjk8kn";
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ aeson base binary bytestring cmdargs conduit conduit-extra
+ connection containers deepseq directory extra filepath
+ haskell-src-exts http-conduit http-types js-flot js-jquery mmap
+ network network-uri old-locale process process-extras QuickCheck
+ resourcet tar template-haskell text time transformers uniplate
+ utf8-string vector wai wai-logger warp warp-tls zlib
+ ];
+ executableHaskellDepends = [ base ];
+ testTarget = "--test-option=--no-net";
+ homepage = "http://hoogle.haskell.org/";
+ description = "Haskell API Search";
+ license = stdenv.lib.licenses.bsd3;
+}