aboutsummaryrefslogtreecommitdiff
path: root/pkgs/check_solr/cabal2nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/check_solr/cabal2nix.nix')
-rw-r--r--pkgs/check_solr/cabal2nix.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/check_solr/cabal2nix.nix b/pkgs/check_solr/cabal2nix.nix
new file mode 100644
index 0000000..138062f
--- /dev/null
+++ b/pkgs/check_solr/cabal2nix.nix
@@ -0,0 +1,23 @@
+{ mkDerivation, aeson, base, base64-bytestring, bytestring, docopt
+, fetchgit, HTTP, http-conduit, nagios-check, raw-strings-qq
+, regex-tdfa, scientific, stdenv, text, unordered-containers
+}:
+mkDerivation {
+ pname = "check-solr";
+ version = "0.1.0";
+ src = fetchgit {
+ url = "https://github.com/ip1981/check-solr.git";
+ sha256 = "0hama3kglnn4kyzkssl1llb61kcgyhynpbbk6xsf015hvi90hsa0";
+ rev = "869c945fb56f0ff187125ee352a6876002eba596";
+ };
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ aeson base base64-bytestring bytestring docopt HTTP http-conduit
+ nagios-check raw-strings-qq regex-tdfa scientific text
+ unordered-containers
+ ];
+ executableHaskellDepends = [ base docopt raw-strings-qq ];
+ description = "Icinga / Nagios plugin for Solr";
+ license = stdenv.lib.licenses.mit;
+}