aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/writeBashScript.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pkgs/writeBashScript.nix')
-rw-r--r--modules/pkgs/writeBashScript.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/modules/pkgs/writeBashScript.nix b/modules/pkgs/writeBashScript.nix
deleted file mode 100644
index b193122..0000000
--- a/modules/pkgs/writeBashScript.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-{ bash, writeTextFile, haskellPackages }:
-
-let
-
- shellcheck = haskellPackages.ShellCheck;
-
-in
-
-name: text:
- writeTextFile
- {
- inherit name;
- executable = true;
- text = ''
- #!${bash}/bin/bash
- ${text}
- '';
- checkPhase = ''
- ${shellcheck}/bin/shellcheck "$out"
- '';
- }