aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/mariadb
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pkgs/mariadb')
-rw-r--r--modules/pkgs/mariadb/MDEV-10463.patch36
-rw-r--r--modules/pkgs/mariadb/default.nix5
2 files changed, 2 insertions, 39 deletions
diff --git a/modules/pkgs/mariadb/MDEV-10463.patch b/modules/pkgs/mariadb/MDEV-10463.patch
deleted file mode 100644
index c094257..0000000
--- a/modules/pkgs/mariadb/MDEV-10463.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/sql/sql_show.cc b/sql/sql_show.cc
-index ae38745..73edb18 100644
---- a/sql/sql_show.cc
-+++ b/sql/sql_show.cc
-@@ -4850,6 +4850,7 @@ int fill_schema_schemata(THD *thd, TABLE_LIST *tables, COND *cond)
- TABLE *table= tables->table;
- #ifndef NO_EMBEDDED_ACCESS_CHECKS
- Security_context *sctx= thd->security_ctx;
-+ ulong db_access= sctx->db_access;
- #endif
- DBUG_ENTER("fill_schema_shemata");
-
-@@ -4891,9 +4892,20 @@ int fill_schema_schemata(THD *thd, TABLE_LIST *tables, COND *cond)
- continue;
- }
- #ifndef NO_EMBEDDED_ACCESS_CHECKS
-- if (sctx->master_access & (DB_ACLS | SHOW_DB_ACL) ||
-- acl_get(sctx->host, sctx->ip, sctx->priv_user, db_name->str, 0) ||
-- !check_grant_db(thd, db_name->str))
-+ if (test_all_bits(sctx->master_access, DB_ACLS))
-+ db_access= DB_ACLS;
-+ else
-+ {
-+ db_access= acl_get(sctx->host, sctx->ip, sctx->priv_user, db_name->str, FALSE);
-+ if (sctx->priv_role[0])
-+ {
-+ /* include a possible currently set role for access */
-+ db_access|= acl_get("", "", sctx->priv_role, db_name->str, FALSE);
-+ }
-+ }
-+ if ((sctx->master_access & SHOW_DB_ACL) ||
-+ (db_access & DB_ACLS) ||
-+ !check_grant_db(thd, db_name->str))
- #endif
- {
- load_db_opt_by_name(thd, db_name->str, &create);
diff --git a/modules/pkgs/mariadb/default.nix b/modules/pkgs/mariadb/default.nix
index 4dee4d0..a08c45f 100644
--- a/modules/pkgs/mariadb/default.nix
+++ b/modules/pkgs/mariadb/default.nix
@@ -14,11 +14,11 @@ mariadb = everything // {
};
common = rec { # attributes common to both builds
- version = "10.1.24";
+ version = "10.1.26";
src = fetchurl {
url = "https://downloads.mariadb.org/interstitial/mariadb-${version}/source/mariadb-${version}.tar.gz";
- sha256 = "07jm9m7d5x4zdpasdjs98m36dkjl7ypc9jz4xmnczj0ybfp9kpxk";
+ sha256 = "0ggpdcal0if9y6h9hp1yv2q65cbkjfl4p8rqk68a5pk7k75v325s";
};
prePatch = ''
@@ -93,7 +93,6 @@ everything = stdenv.mkDerivation (common // {
name = "mariadb-${common.version}";
patches = [
- ./MDEV-10463.patch
./MDEV-12366.patch
];