aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/ldapply/ldap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pkgs/ldapply/ldap.nix')
-rw-r--r--modules/pkgs/ldapply/ldap.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/pkgs/ldapply/ldap.nix b/modules/pkgs/ldapply/ldap.nix
new file mode 100644
index 0000000..75b5f64
--- /dev/null
+++ b/modules/pkgs/ldapply/ldap.nix
@@ -0,0 +1,17 @@
+{ mkDerivation, base, fetchgit, HUnit, openldap, stdenv }:
+mkDerivation {
+ pname = "LDAP";
+ version = "0.7.0";
+ src = fetchgit {
+ url = "https://github.com/ip1981/ldap-haskell.git";
+ sha256 = "1lb746ifqz216cxgxli30r30bx49f8l1an4k4w7sa87gdchjka4y";
+ rev = "1d47f5712fc09bbf00c49bb58907aaf355fdf2e2";
+ };
+ libraryHaskellDepends = [ base ];
+ librarySystemDepends = [ openldap ];
+ testHaskellDepends = [ base HUnit ];
+ testSystemDepends = [ openldap ];
+ homepage = "https://github.com/ezyang/ldap-haskell";
+ description = "Haskell binding for C LDAP API";
+ license = stdenv.lib.licenses.bsd3;
+}