aboutsummaryrefslogtreecommitdiff
path: root/apps/strongswan/options/ca.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apps/strongswan/options/ca.nix')
-rw-r--r--apps/strongswan/options/ca.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/apps/strongswan/options/ca.nix b/apps/strongswan/options/ca.nix
new file mode 100644
index 0000000..e52b088
--- /dev/null
+++ b/apps/strongswan/options/ca.nix
@@ -0,0 +1,20 @@
+{ config, lib, ... }:
+
+let
+
+ inherit (lib) foldl;
+ inherit (lib.types) str path enum;
+ inherit (import ./lib.nix lib) optional;
+
+in {
+ options = foldl (a: b: a//b) {} [
+ { also = optional str; }
+ { auto = optional (enum [ "add" "ignore" ]); }
+ { cacert = optional path; }
+ { certuribase = optional str; }
+ { crluri = optional str; }
+ { crluri2 = optional str; }
+ { ocspuri = optional str; }
+ { ocspuri2 = optional str; }
+ ];
+}