aboutsummaryrefslogtreecommitdiff
path: root/pkgs/writeXML.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
commit8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3 (patch)
treed03b70f693463fc836a8dbe4240424d2547530c8 /pkgs/writeXML.nix
parentc4273035cf5876e3ba8ed2c6b492d31c2de290ee (diff)
downloadnixsap-8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3.tar.gz
(* HUGE *) Use nixpkgs overlays
Diffstat (limited to 'pkgs/writeXML.nix')
-rw-r--r--pkgs/writeXML.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/pkgs/writeXML.nix b/pkgs/writeXML.nix
new file mode 100644
index 0000000..9ad3826
--- /dev/null
+++ b/pkgs/writeXML.nix
@@ -0,0 +1,12 @@
+{ writeTextFile, libxml2 }:
+
+name: text:
+ writeTextFile
+ {
+ inherit name text;
+ checkPhase = ''
+ ${libxml2.bin}/bin/xmllint \
+ --format --noblanks --nocdata "$out" > linted
+ mv linted "$out"
+ '';
+ }