aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sproxy-web
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-09-23 12:41:01 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-09-23 12:41:49 +0300
commitaf337a12e6f084556400fa93c71304ad63f1efa6 (patch)
treead5125cbfb2e812f4a507b182b875526b2a2d0e9 /pkgs/sproxy-web
downloadnixsap-af337a12e6f084556400fa93c71304ad63f1efa6.tar.gz
Initial commit
Diffstat (limited to 'pkgs/sproxy-web')
-rw-r--r--pkgs/sproxy-web/cabal2nix.nix26
-rw-r--r--pkgs/sproxy-web/default.nix4
2 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/sproxy-web/cabal2nix.nix b/pkgs/sproxy-web/cabal2nix.nix
new file mode 100644
index 0000000..0f475f2
--- /dev/null
+++ b/pkgs/sproxy-web/cabal2nix.nix
@@ -0,0 +1,26 @@
+{ mkDerivation, aeson, base, blaze-html, blaze-markup, bytestring
+, data-default-class, directory, docopt, fast-logger, fetchgit
+, filepath, http-types, interpolatedstring-perl6, mtl, network
+, postgresql-simple, resource-pool, scotty, stdenv, text, unix, wai
+, wai-extra, wai-middleware-static, warp
+}:
+mkDerivation {
+ pname = "sproxy-web";
+ version = "0.4.1";
+ src = fetchgit {
+ url = "https://github.com/zalora/sproxy-web.git";
+ sha256 = "529597548a3fbd0999acdbd3a382ed4f152043db01f275b08d4c4883b8fe5f5f";
+ rev = "5d7ee61deb55359ae8ce6013dd7fe81bcdc0f9a9";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base blaze-html blaze-markup bytestring data-default-class
+ directory docopt fast-logger filepath http-types
+ interpolatedstring-perl6 mtl network postgresql-simple
+ resource-pool scotty text unix wai wai-extra wai-middleware-static
+ warp
+ ];
+ description = "Web interface to sproxy database";
+ license = stdenv.lib.licenses.mit;
+}
diff --git a/pkgs/sproxy-web/default.nix b/pkgs/sproxy-web/default.nix
new file mode 100644
index 0000000..4afc645
--- /dev/null
+++ b/pkgs/sproxy-web/default.nix
@@ -0,0 +1,4 @@
+{ stdenv, haskellPackages }:
+
+haskellPackages.callPackage ./cabal2nix.nix {}
+