aboutsummaryrefslogtreecommitdiff
path: root/pkgs/probes.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-09-29 13:51:44 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-09-29 13:51:44 +0300
commit62f28d30a069135f9c48678507203958adfc334f (patch)
tree7f38af0c8d3f445ee8cc50906a639baec7011127 /pkgs/probes.nix
parent1af9e6589bdd18e6ba7eeabf073aa7d710020cdd (diff)
downloadnixsap-62f28d30a069135f9c48678507203958adfc334f.tar.gz
Moved everything into ./modules
Diffstat (limited to 'pkgs/probes.nix')
-rw-r--r--pkgs/probes.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/pkgs/probes.nix b/pkgs/probes.nix
deleted file mode 100644
index 650c996..0000000
--- a/pkgs/probes.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ stdenv, pkgs, lib }:
-
-let
- plugins = [
- "check_disk"
- "check_file_age"
- "check_http"
- "check_load"
- "check_log"
- "check_mysql"
- "check_mysql_query"
- "check_procs"
- "check_swap"
- "check_users"
- ];
-
-in stdenv.mkDerivation {
- name = "local-monitoring-plugins";
- phases = [ "installPhase" ];
- installPhase = ''
- mkdir -p $out/bin
- ${lib.concatMapStringsSep "\n" (p: ''
- cp -a ${pkgs.monitoringPlugins}/libexec/${p} $out/bin/${p}
- '') plugins}
- cp -a '${pkgs.check_mdstat}/bin/'* $out/bin/
- cp -a '${pkgs.check_systemd}/bin/'* $out/bin/
- '';
-}