aboutsummaryrefslogtreecommitdiff
path: root/pkgs/mywatch
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-09-23 12:41:01 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-09-23 12:41:49 +0300
commitaf337a12e6f084556400fa93c71304ad63f1efa6 (patch)
treead5125cbfb2e812f4a507b182b875526b2a2d0e9 /pkgs/mywatch
downloadnixsap-af337a12e6f084556400fa93c71304ad63f1efa6.tar.gz
Initial commit
Diffstat (limited to 'pkgs/mywatch')
-rw-r--r--pkgs/mywatch/cabal2nix.nix25
-rw-r--r--pkgs/mywatch/default.nix4
2 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/mywatch/cabal2nix.nix b/pkgs/mywatch/cabal2nix.nix
new file mode 100644
index 0000000..3dfbbcc
--- /dev/null
+++ b/pkgs/mywatch/cabal2nix.nix
@@ -0,0 +1,25 @@
+{ mkDerivation, aeson, base, bytestring, ConfigFile
+, data-default-class, docopt, fast-logger, fetchgit, http-types
+, interpolatedstring-perl6, MissingH, mtl, mysql, mysql-simple
+, network, resource-pool, scotty, stdenv, text, unix
+, unordered-containers, wai, wai-extra, wai-middleware-static, warp
+}:
+mkDerivation {
+ pname = "mywatch";
+ version = "0.2.0";
+ src = fetchgit {
+ url = "https://github.com/zalora/mywatch.git";
+ sha256 = "f1ae1b776cdbc11da24819381d5d1fe057be3c5ef69314024c9e0fc043085cd2";
+ rev = "afd12c0190f64527a320a99cc6df97f6cfca57d7";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base bytestring ConfigFile data-default-class docopt
+ fast-logger http-types interpolatedstring-perl6 MissingH mtl mysql
+ mysql-simple network resource-pool scotty text unix
+ unordered-containers wai wai-extra wai-middleware-static warp
+ ];
+ description = "Web application to view and kill MySQL queries";
+ license = stdenv.lib.licenses.mit;
+}
diff --git a/pkgs/mywatch/default.nix b/pkgs/mywatch/default.nix
new file mode 100644
index 0000000..4afc645
--- /dev/null
+++ b/pkgs/mywatch/default.nix
@@ -0,0 +1,4 @@
+{ stdenv, haskellPackages }:
+
+haskellPackages.callPackage ./cabal2nix.nix {}
+