aboutsummaryrefslogtreecommitdiff
path: root/pkgs/mathJax.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
commit8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3 (patch)
treed03b70f693463fc836a8dbe4240424d2547530c8 /pkgs/mathJax.nix
parentc4273035cf5876e3ba8ed2c6b492d31c2de290ee (diff)
downloadnixsap-8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3.tar.gz
(* HUGE *) Use nixpkgs overlays
Diffstat (limited to 'pkgs/mathJax.nix')
-rw-r--r--pkgs/mathJax.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/mathJax.nix b/pkgs/mathJax.nix
new file mode 100644
index 0000000..04b596f
--- /dev/null
+++ b/pkgs/mathJax.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+ version = "2.6.1";
+ name = "mathjax-${version}";
+
+ src = fetchurl {
+ url = "https://github.com/mathjax/MathJax/archive/${version}.tar.gz";
+ sha256 = "1f7v48s7km9fi9i0bignn8f91z3bk04n4jx407l3xsd4hxfr8in7";
+ };
+
+ installPhase = ''
+ mkdir -p $out
+ cp -a * $out/
+ rm -rf $out/unpacked
+ rm -rf "$out/"*.json
+ '';
+}