aboutsummaryrefslogtreecommitdiff
path: root/pkgs/icingaweb2/default.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-09-23 12:41:01 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-09-23 12:41:49 +0300
commitaf337a12e6f084556400fa93c71304ad63f1efa6 (patch)
treead5125cbfb2e812f4a507b182b875526b2a2d0e9 /pkgs/icingaweb2/default.nix
downloadnixsap-af337a12e6f084556400fa93c71304ad63f1efa6.tar.gz
Initial commit
Diffstat (limited to 'pkgs/icingaweb2/default.nix')
-rw-r--r--pkgs/icingaweb2/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/icingaweb2/default.nix b/pkgs/icingaweb2/default.nix
new file mode 100644
index 0000000..263ae47
--- /dev/null
+++ b/pkgs/icingaweb2/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchurl
+, php
+}:
+
+stdenv.mkDerivation rec {
+ version = "2.3.4";
+ name = "icingaweb2-${version}";
+
+ src = fetchurl {
+ url = "https://github.com/Icinga/icingaweb2/archive/v${version}.tar.gz";
+ sha256 = "0kmxvwbr7g6daj2mqabzvmw3910igd85wrzwilkz83fizgmrszh5";
+ };
+
+ buildInputs = [ php ];
+
+ patches = [ ./sproxy.patch ];
+
+ buildPhase = "true";
+
+ installPhase = ''
+ mkdir -p $out
+ cp -a * $out
+ rm -rf $out/.puppet
+ rm -rf $out/Vagrantfile
+ rm -rf $out/icingaweb2.spec
+ rm -rf $out/modules/doc
+ rm -rf $out/modules/iframe
+ rm -rf $out/modules/setup
+ rm -rf $out/modules/test
+ rm -rf $out/packages
+ rm -rf $out/test
+ '';
+}