aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/sproxy2/main.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-11-18 16:08:19 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-11-19 23:31:42 +0300
commit9fc9a7b935d051f388550ceab6262c9d733de180 (patch)
treeaea227ef054b114df330637b387e0cdfee5e7c7e /modules/pkgs/sproxy2/main.nix
parente7877a45fd955b8c94494708656a3d62d8b82cac (diff)
downloadnixsap-9fc9a7b935d051f388550ceab6262c9d733de180.tar.gz
Added sproxy2
Diffstat (limited to 'modules/pkgs/sproxy2/main.nix')
-rw-r--r--modules/pkgs/sproxy2/main.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/pkgs/sproxy2/main.nix b/modules/pkgs/sproxy2/main.nix
new file mode 100644
index 0000000..0de4cc0
--- /dev/null
+++ b/modules/pkgs/sproxy2/main.nix
@@ -0,0 +1,28 @@
+{ mkDerivation, aeson, base, base64-bytestring, blaze-builder
+, bytestring, cereal, conduit, containers, cookie, docopt, entropy
+, fetchgit, Glob, http-client, http-conduit, http-types
+, interpolatedstring-perl6, network, postgresql-simple
+, resource-pool, SHA, sqlite-simple, stdenv, text, time, unix
+, unordered-containers, wai, wai-conduit, warp, warp-tls, word8
+, yaml
+}:
+mkDerivation {
+ pname = "sproxy2";
+ version = "1.90.0";
+ src = fetchgit {
+ url = "https://github.com/ip1981/sproxy2.git";
+ sha256 = "1dpdaparvrd3ykwpac99wqfsnywqvbvscdj7j3v2xyc1sa4vbkda";
+ rev = "4a9f329a6ea9bfa03352ca0d9dd1d556b93bec36";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base base64-bytestring blaze-builder bytestring cereal
+ conduit containers cookie docopt entropy Glob http-client
+ http-conduit http-types interpolatedstring-perl6 network
+ postgresql-simple resource-pool SHA sqlite-simple text time unix
+ unordered-containers wai wai-conduit warp warp-tls word8 yaml
+ ];
+ description = "Secure HTTP proxy for authenticating users via OAuth2";
+ license = stdenv.lib.licenses.mit;
+}