aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/nodejs-sass/main.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2017-07-12 21:27:18 +0300
committerIgor Pashev <pashev.igor@gmail.com>2017-07-12 21:48:55 +0300
commitc6f46f47c947a7f19918adcbe28089556496b8b7 (patch)
treed00e3117be7625869841be2bc109e96d063320ac /modules/pkgs/nodejs-sass/main.nix
parentc3ca2aa2029765cbee664ecc05254ad522a552fb (diff)
downloadnixsap-c6f46f47c947a7f19918adcbe28089556496b8b7.tar.gz
nodejs-sass: init at 4.5.3
*WARNING* This was added to make sure npm won't download any pre-built binaries (sic!). Instead it will build sass bindings in place, using bundled libsass (ok). preRebuild = '' SASS_FORCE_BUILD=true npm run-script build '';
Diffstat (limited to 'modules/pkgs/nodejs-sass/main.nix')
-rw-r--r--modules/pkgs/nodejs-sass/main.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/pkgs/nodejs-sass/main.nix b/modules/pkgs/nodejs-sass/main.nix
new file mode 100644
index 0000000..2eef6d7
--- /dev/null
+++ b/modules/pkgs/nodejs-sass/main.nix
@@ -0,0 +1,16 @@
+# This file has been generated by node2nix 1.2.0. Do not edit!
+
+{pkgs ? import <nixpkgs> {
+ inherit system;
+ }, system ? builtins.currentSystem, nodejs ? pkgs."nodejs-4_x"}:
+
+let
+ nodeEnv = import ./node-env.nix {
+ inherit (pkgs) stdenv python2 utillinux runCommand writeTextFile;
+ inherit nodejs;
+ };
+in
+import ./node-packages.nix {
+ inherit (pkgs) fetchurl fetchgit;
+ inherit nodeEnv;
+}