aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/mywatch/main.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-11-18 14:42:54 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-11-18 14:42:57 +0300
commitf145b1b1fbd392dd9f539744c76142b142cce4e9 (patch)
tree8681d17a2906516a5dc45c399cbf0bbf0365aaea /modules/pkgs/mywatch/main.nix
parent7c370412257c6ad1b432d00ae6a0700b0b04f7fa (diff)
downloadnixsap-f145b1b1fbd392dd9f539744c76142b142cce4e9.tar.gz
Override haskell mysql to disable tests
mysql and mysql-simple try to connect to local mysql See https://github.com/NixOS/nixpkgs/issues/20478
Diffstat (limited to 'modules/pkgs/mywatch/main.nix')
-rw-r--r--modules/pkgs/mywatch/main.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/pkgs/mywatch/main.nix b/modules/pkgs/mywatch/main.nix
new file mode 100644
index 0000000..7f72b5f
--- /dev/null
+++ b/modules/pkgs/mywatch/main.nix
@@ -0,0 +1,25 @@
+{ mkDerivation, aeson, base, bytestring, ConfigFile
+, data-default-class, docopt, fast-logger, fetchgit, http-types
+, interpolatedstring-perl6, MissingH, mtl, mysql, mysql-simple
+, network, resource-pool, scotty, stdenv, text, unix
+, unordered-containers, wai, wai-extra, wai-middleware-static, warp
+}:
+mkDerivation {
+ pname = "mywatch";
+ version = "0.2.1";
+ src = fetchgit {
+ url = "https://github.com/zalora/mywatch.git";
+ sha256 = "7c646cb69958fd1010682873c193afad0f5d93a4abb8f5ce728c0500fb43912b";
+ rev = "523b6029eb4b8569504086dfb5b8538330e5f522";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base bytestring ConfigFile data-default-class docopt
+ fast-logger http-types interpolatedstring-perl6 MissingH mtl mysql
+ mysql-simple network resource-pool scotty text unix
+ unordered-containers wai wai-extra wai-middleware-static warp
+ ];
+ description = "Web application to view and kill MySQL queries";
+ license = stdenv.lib.licenses.mit;
+}