aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/mathJax.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-09-29 13:51:44 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-09-29 13:51:44 +0300
commit62f28d30a069135f9c48678507203958adfc334f (patch)
tree7f38af0c8d3f445ee8cc50906a639baec7011127 /modules/pkgs/mathJax.nix
parent1af9e6589bdd18e6ba7eeabf073aa7d710020cdd (diff)
downloadnixsap-62f28d30a069135f9c48678507203958adfc334f.tar.gz
Moved everything into ./modules
Diffstat (limited to 'modules/pkgs/mathJax.nix')
-rw-r--r--modules/pkgs/mathJax.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/pkgs/mathJax.nix b/modules/pkgs/mathJax.nix
new file mode 100644
index 0000000..04b596f
--- /dev/null
+++ b/modules/pkgs/mathJax.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+ version = "2.6.1";
+ name = "mathjax-${version}";
+
+ src = fetchurl {
+ url = "https://github.com/mathjax/MathJax/archive/${version}.tar.gz";
+ sha256 = "1f7v48s7km9fi9i0bignn8f91z3bk04n4jx407l3xsd4hxfr8in7";
+ };
+
+ installPhase = ''
+ mkdir -p $out
+ cp -a * $out/
+ rm -rf $out/unpacked
+ rm -rf "$out/"*.json
+ '';
+}