aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/mariadb
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-01-07 19:56:41 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-01-07 19:56:41 +0300
commit769c61bc91a30afe129539932629a408eee1fdc3 (patch)
treee300276db43261461d244e1cfaea125a23241780 /modules/pkgs/mariadb
parent110325c1727090f8e756a6db8fdb1f706b91416b (diff)
downloadnixsap-769c61bc91a30afe129539932629a408eee1fdc3.tar.gz
MariaDB: 10.1.26 -> 10.1.30
* Remove MDEV-12366.patch (fixed upstream) * Switch to bundled PCRE For PCRE see: * https://bugs.exim.org/show_bug.cgi?id=2173 * https://jira.mariadb.org/browse/MDEV-14024 * https://github.com/NixOS/nixpkgs/commit/462076c909f10efd460595f2090a7cf76d595b74 While it is a common virtue to use "system" libraries, this is not a big deal in Nix because there is no "system" libraries.
Diffstat (limited to 'modules/pkgs/mariadb')
-rw-r--r--modules/pkgs/mariadb/MDEV-12366.patch17
-rw-r--r--modules/pkgs/mariadb/default.nix11
2 files changed, 5 insertions, 23 deletions
diff --git a/modules/pkgs/mariadb/MDEV-12366.patch b/modules/pkgs/mariadb/MDEV-12366.patch
deleted file mode 100644
index 524ca58..0000000
--- a/modules/pkgs/mariadb/MDEV-12366.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: Fix FLUSH PRIVILEGES can miss some roles
-Bug: https://jira.mariadb.org/browse/MDEV-12366
-diff --git a/sql/sql_acl.cc b/sql/sql_acl.cc
-index cb4c3cb1049..bf6a7b847f5 100644
---- a/sql/sql_acl.cc
-+++ b/sql/sql_acl.cc
-@@ -6754,9 +6754,7 @@ static my_bool role_propagate_grants_action(void *ptr,
- if (role->counter)
- return 0;
-
-- mysql_mutex_assert_owner(&acl_cache->lock);
-- PRIVS_TO_MERGE data= { PRIVS_TO_MERGE::ALL, 0, 0 };
-- traverse_role_graph_up(role, &data, NULL, merge_role_privileges);
-+ propagate_role_grants(role, PRIVS_TO_MERGE::ALL, NULL, NULL);
- return 0;
- }
-
diff --git a/modules/pkgs/mariadb/default.nix b/modules/pkgs/mariadb/default.nix
index a08c45f..e4c595a 100644
--- a/modules/pkgs/mariadb/default.nix
+++ b/modules/pkgs/mariadb/default.nix
@@ -1,5 +1,5 @@
{ stdenv, fetchurl, cmake, pkgconfig, ncurses, zlib, xz, lzo, lz4, bzip2, snappy
-, openssl, pcre, boost, judy, bison, libxml2
+, openssl, boost, judy, bison, libxml2
, libaio, libevent, groff, jemalloc, cracklib, systemd, numactl, perl
}:
@@ -14,11 +14,11 @@ mariadb = everything // {
};
common = rec { # attributes common to both builds
- version = "10.1.26";
+ version = "10.1.30";
src = fetchurl {
url = "https://downloads.mariadb.org/interstitial/mariadb-${version}/source/mariadb-${version}.tar.gz";
- sha256 = "0ggpdcal0if9y6h9hp1yv2q65cbkjfl4p8rqk68a5pk7k75v325s";
+ sha256 = "123ck7q5lk535qm8i5b0gk1pc5j9k1f9pl1vki30m7l14id5wfhp";
};
prePatch = ''
@@ -29,7 +29,7 @@ common = rec { # attributes common to both builds
nativeBuildInputs = [ cmake pkgconfig ];
- buildInputs = [ ncurses openssl zlib pcre jemalloc libaio systemd ];
+ buildInputs = [ ncurses openssl zlib jemalloc libaio systemd ];
cmakeFlags = [
"-DBUILD_CONFIG=mysql_release"
@@ -43,7 +43,7 @@ common = rec { # attributes common to both builds
"-DWITH_ZLIB=system"
"-DWITH_SSL=system"
- "-DWITH_PCRE=system"
+ "-DWITH_PCRE=auto"
]
;
@@ -93,7 +93,6 @@ everything = stdenv.mkDerivation (common // {
name = "mariadb-${common.version}";
patches = [
- ./MDEV-12366.patch
];
nativeBuildInputs = common.nativeBuildInputs ++ [ bison ];