aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/ldapply/main.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2017-01-06 19:46:58 +0300
committerIgor Pashev <pashev.igor@gmail.com>2017-01-07 21:49:41 +0300
commit5ad946d06df56dbd395e4fef88a0b9581d1b4429 (patch)
tree38061dbffc22caae40aff53145c17c2706443c2c /modules/pkgs/ldapply/main.nix
parent44d2e9662af80e30c8fc0516616a3a8c40b17837 (diff)
downloadnixsap-5ad946d06df56dbd395e4fef88a0b9581d1b4429.tar.gz
Added ldapply 0.1.0+
LDIF idempotent apply tool
Diffstat (limited to 'modules/pkgs/ldapply/main.nix')
-rw-r--r--modules/pkgs/ldapply/main.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/pkgs/ldapply/main.nix b/modules/pkgs/ldapply/main.nix
new file mode 100644
index 0000000..7c6f075
--- /dev/null
+++ b/modules/pkgs/ldapply/main.nix
@@ -0,0 +1,21 @@
+{ mkDerivation, base, bytestring, docopt, fetchgit
+, interpolatedstring-perl6, LDAP, ldif, stdenv
+, unordered-containers
+}:
+mkDerivation {
+ pname = "ldapply";
+ version = "0.1.0";
+ src = fetchgit {
+ url = "https://github.com/ip1981/ldapply.git";
+ sha256 = "0vmq6l49hiyc20rv6xqj518m6bn7291ampjd1yf2b6w79isx3zfg";
+ rev = "cdddf52e87b0b7a84b9b664df29004340f99ec20";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ base bytestring docopt interpolatedstring-perl6 LDAP ldif
+ unordered-containers
+ ];
+ description = "LDIF idempotent apply tool";
+ license = stdenv.lib.licenses.mit;
+}