aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/kibana5/default.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
commit8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3 (patch)
treed03b70f693463fc836a8dbe4240424d2547530c8 /modules/pkgs/kibana5/default.nix
parentc4273035cf5876e3ba8ed2c6b492d31c2de290ee (diff)
downloadnixsap-8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3.tar.gz
(* HUGE *) Use nixpkgs overlays
Diffstat (limited to 'modules/pkgs/kibana5/default.nix')
-rw-r--r--modules/pkgs/kibana5/default.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/modules/pkgs/kibana5/default.nix b/modules/pkgs/kibana5/default.nix
deleted file mode 100644
index 519dafd..0000000
--- a/modules/pkgs/kibana5/default.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ stdenv, fetchurl }:
-
-stdenv.mkDerivation rec {
- name = "kibana-${version}.tar.xz";
- version = "5.0.2";
-
- # JS is a realm of sorrow. node2nix, npm2nix failed to package kibana
- # mostly because of npm and its registry being dumb beasts.
- # Instead, we are loading prebuild package. It's arch-dependent
- # only for bundled Node.JS binary (sic!). We remove it, and use our own.
- # This also makes it easier to patch the whole thing when needed.
- # Even worse: kibana can't run from a read-only directory.
- # So we will keep it in a tarball and extract before running.
- # Essentially it's like Java's WAR archives.
- src = fetchurl {
- url = "https://artifacts.elastic.co/downloads/kibana/kibana-${version}-linux-x86_64.tar.gz";
- sha1 = "c68eb5d3397a0afb7132630f120b1d53724a2fd9";
- };
-
- phases = [ "unpackPhase" "installPhase" ];
-
- installPhase = ''
- rm -r node bin
- tar cJf $out --transform 's,^,kibana-${version}/,' *
- '';
-
- meta = {
- description = "Visualize logs and time-stamped data";
- homepage = http://www.elasticsearch.org/overview/kibana;
- license = stdenv.lib.licenses.asl20;
- };
-}