aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/juandelacosa/main.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-11-18 14:42:54 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-11-18 14:42:57 +0300
commitf145b1b1fbd392dd9f539744c76142b142cce4e9 (patch)
tree8681d17a2906516a5dc45c399cbf0bbf0365aaea /modules/pkgs/juandelacosa/main.nix
parent7c370412257c6ad1b432d00ae6a0700b0b04f7fa (diff)
downloadnixsap-f145b1b1fbd392dd9f539744c76142b142cce4e9.tar.gz
Override haskell mysql to disable tests
mysql and mysql-simple try to connect to local mysql See https://github.com/NixOS/nixpkgs/issues/20478
Diffstat (limited to 'modules/pkgs/juandelacosa/main.nix')
-rw-r--r--modules/pkgs/juandelacosa/main.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/pkgs/juandelacosa/main.nix b/modules/pkgs/juandelacosa/main.nix
new file mode 100644
index 0000000..ddb6af7
--- /dev/null
+++ b/modules/pkgs/juandelacosa/main.nix
@@ -0,0 +1,25 @@
+{ mkDerivation, base, base64-bytestring, bytestring
+, data-default-class, docopt, entropy, fast-logger, fetchgit
+, http-types, interpolatedstring-perl6, mtl, mysql, mysql-simple
+, network, resource-pool, scotty, stdenv, text, unix, wai
+, wai-extra, wai-middleware-static, warp
+}:
+mkDerivation {
+ pname = "juandelacosa";
+ version = "0.1.1";
+ src = fetchgit {
+ url = "https://github.com/zalora/juandelacosa.git";
+ sha256 = "c260feae989f518484881e7dc7ebcd51d5b25fcda92412445942a5e34c1f9459";
+ rev = "0940da0cdfb1201768d35c58433891feacbaedd5";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ base base64-bytestring bytestring data-default-class docopt entropy
+ fast-logger http-types interpolatedstring-perl6 mtl mysql
+ mysql-simple network resource-pool scotty text unix wai wai-extra
+ wai-middleware-static warp
+ ];
+ description = "Manage users in MariaDB >= 10.1.1";
+ license = stdenv.lib.licenses.mit;
+}