aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/jenkins/instance.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-09-15 15:59:02 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-09-15 15:59:05 +0300
commitd45a3021ea22eb9d088abf7af27367f6d39b56cf (patch)
tree9c350b7b1d80a3db770fc5b429c32954d10d6ee8 /modules/apps/jenkins/instance.nix
parent22f1d377210266a8389bbe6db5eb49972aa64cc3 (diff)
downloadnixsap-d45a3021ea22eb9d088abf7af27367f6d39b56cf.tar.gz
Support node configuration in Jenkins
Similar to jobs.
Diffstat (limited to 'modules/apps/jenkins/instance.nix')
-rw-r--r--modules/apps/jenkins/instance.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/apps/jenkins/instance.nix b/modules/apps/jenkins/instance.nix
index 6cca8a4..89c5c93 100644
--- a/modules/apps/jenkins/instance.nix
+++ b/modules/apps/jenkins/instance.nix
@@ -62,6 +62,15 @@ in {
default = true;
};
+ nodes = mkOption {
+ description = ''
+ Nodes. Each value is either inline XML text or an XML file.
+ Any existing nodes, not mentioned here, are physically removed.
+ '';
+ type = attrsOf (either str path);
+ default = {};
+ };
+
jobs = mkOption {
description = ''
Jenkins jobs. Each value is either inline XML text or an XML file.