summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..bf979c8
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,29 @@
+## Process this file with automake to create Makefile.in.
+
+## Makefile for GNU make documentation.
+## Copyright 2002 Free Software Foundation, Inc.
+
+TEXI2HTML = texi2html
+TEXI2HTML_FLAGS = -split_chapter
+
+info_TEXINFOS = make.texi
+make_TEXINFOS = fdl.texi make-stds.texi
+
+CLEANFILES = make*.html make*.pdf
+
+## ----------------------------- ##
+## Other documentation formats. ##
+## ----------------------------- ##
+
+html: make_1.html
+
+make_1.html: $(info_TEXINFOS) $(make_TEXINFOS)
+ $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/make.texi
+
+
+pdf: make.pdf
+
+make.pdf: $(info_TEXINFOS) $(make_TEXINFOS)
+ $(TEXI2DVI) --pdf --batch $(srcdir)/make.texi
+
+.PHONY: html pdf