summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index da37bc9..4bad3e2 100644
--- a/configure.in
+++ b/configure.in
@@ -391,16 +391,16 @@ esac
# Specify what files are to be created.
AC_CONFIG_FILES(Makefile glob/Makefile po/Makefile.in config/Makefile doc/Makefile)
-# We only generate the build.sh if we have a build.sh.in; we won't have
-# one before we've created a distribution.
-m4_syscmd([test -f build.sh.in])dnl
-m4_if(m4_sysval, 0, [AC_CONFIG_FILES(build.sh)])
-
-
# OK, do it!
AC_OUTPUT
+# We only generate the build.sh if we have a build.sh.in; we won't have
+# one before we've created a distribution.
+if test -f build.sh.in; then
+ ./config.status --file build.sh
+ chmod +x build.sh
+fi
dnl Local Variables:
dnl comment-start: "dnl "