summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4bcf56f..f62c192 100644
--- a/configure.in
+++ b/configure.in
@@ -136,6 +136,18 @@ case "$ac_cv_func_pipe $make_cv_job_server" in
"yes yes") AC_DEFINE(MAKE_JOBSERVER) ;;
esac
+dnl Allow building with dmalloc
+
+AC_ARG_ENABLE(dmalloc,
+ [ --enable-dmalloc Enable support for the dmalloc debugging library],
+ [make_cv_dmalloc="$enableval"],
+ [make_cv_dmalloc="no"])
+
+case "$make_cv_dmalloc" in
+ yes) AC_CHECK_HEADERS(dmalloc.h)
+ AC_CHECK_LIB(dmalloc, dmalloc_shutdown)
+ CPPFLAGS="$CPPFLAGS -DDMALLOC_FUNC_CHECK" ;;
+esac
AC_CACHE_CHECK(for location of SCCS get command, make_cv_path_sccs_get, [
if test -f /usr/sccs/get; then