summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2afb6b9..e00cc6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -121,10 +121,13 @@ check-loadavg: loadavg
# The loadavg function is invoked during "make check" to test getloadavg.
noinst_PROGRAMS = loadavg
-loadavg_SOURCES = getloadavg.c
+loadavg_SOURCES = loadavg.c
loadavg_CFLAGS = -DTEST
loadavg_LDADD = @GETLOADAVG_LIBS@
+loadavg.c: $(srcdir)/getloadavg.c
+ cp $(srcdir)/getloadavg.c loadavg.c
+
# > check-regression
#
# Look for the make test suite, and run it if found and we can find perl.