summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2010-07-19 07:10:53 +0000
committerPaul Smith <psmith@gnu.org>2010-07-19 07:10:53 +0000
commitfba20a776da6d4a36db21d9b21e9e937bef00ac3 (patch)
tree4cf2063962595ca40234d4832a00f7eeb7ebb321 /configure.in
parentdf2fa7c5a5726b4e0a50e0eff209a3518ab19603 (diff)
downloadgunmake-fba20a776da6d4a36db21d9b21e9e937bef00ac3.tar.gz
- Many fixup patches from Savannah.
- Fix the test suite on Solaris (from Boris) - Update the manual for .ONESHELL
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ab43ce3..b0dd44b 100644
--- a/configure.in
+++ b/configure.in
@@ -148,17 +148,22 @@ if test "$ac_cv_func_gettimeofday" = yes; then
fi
AC_CHECK_FUNCS( strdup strndup mkstemp mktemp fdopen fileno \
- bsd_signal dup2 getcwd realpath sigsetmask sigaction \
+ dup2 getcwd realpath sigsetmask sigaction \
getgroups seteuid setegid setlinebuf setreuid setregid \
getrlimit setrlimit setvbuf pipe strerror strsignal \
lstat readlink atexit)
+# We need to check declarations, not just existence, because on Tru64 this
+# function is not declared without special flags, which themselves cause
+# other problems. We'll just use our own.
+AC_CHECK_DECLS([bsd_signal], [], [], [[#include <signal.h>]])
+
AC_FUNC_SETVBUF_REVERSED
# Rumor has it that strcasecmp lives in -lresolv on some odd systems.
# It doesn't hurt much to use our own if we can't find it so I don't
# make the effort here.
-AC_CHECK_FUNCS(strcasecmp strcmpi stricmp)
+AC_CHECK_FUNCS(strcasecmp strncasecmp strcmpi strncmpi stricmp strnicmp)
# strcoll() is used by the GNU glob library
AC_FUNC_STRCOLL