summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2001-06-01 03:56:50 +0000
committerPaul Smith <psmith@gnu.org>2001-06-01 03:56:50 +0000
commitce2c6eadf1a7f49465a51a4377f2705ce637715c (patch)
tree4e3fe9abeb5b51cd37f36f139e71ee9c79527374 /configure.in
parent5d582d4ba06495a95854c45828399f7edfe51a50 (diff)
downloadgunmake-ce2c6eadf1a7f49465a51a4377f2705ce637715c.tar.gz
Fix for EINTR problems when using jobserver.
New translation files. Fix for @+ inside define macros being applied too widely. Various other bug fixes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 19 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index b5d109d..fc5a477 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,7 @@ AC_REVISION([$Id$])
AC_PREREQ(2.13)dnl dnl Minimum Autoconf version required.
AC_INIT(vpath.c)dnl dnl A distinctive file to look for in srcdir.
-AM_INIT_AUTOMAKE(make, 3.79.1.0)
+AM_INIT_AUTOMAKE(make, 3.79.1.90)
AM_CONFIG_HEADER(config.h)
dnl Regular configure stuff
@@ -42,7 +42,7 @@ AC_HEADER_TIME
dnl Handle internationalization
-ALL_LINGUAS="de es fr gl ja ko nl pl pt_BR ru"
+ALL_LINGUAS="de es fr gl ja ko nl pl pt_BR ru tr"
pds_WITH_GETTEXT
jm_AC_TYPE_UINTMAX_T
@@ -113,8 +113,9 @@ if test $ac_cv_func_gettimeofday = yes; then
fi
AC_CHECK_FUNCS( memmove memcpy strchr strdup psignal mkstemp mktemp fdopen \
- dup2 getcwd sigsetmask sigaction getgroups setlinebuf \
- seteuid setegid setreuid setregid pipe strerror strsignal)
+ bsd_signal dup2 getcwd sigsetmask sigaction getgroups \
+ setlinebuf seteuid setegid setreuid setregid pipe \
+ strerror strsignal)
AC_CHECK_SYMBOL(sys_siglist)
AC_FUNC_ALLOCA
@@ -196,9 +197,20 @@ case "$ac_cv_func_waitpid/$ac_cv_func_wait3" in
no/no) has_wait_nohang=no ;;
esac
-case "$ac_cv_func_pipe/$ac_cv_func_sigaction/$has_wait_nohang/$make_cv_job_server" in
- yes/yes/yes/yes) AC_DEFINE(MAKE_JOBSERVER, 1,
- [Define this to enable job server support in GNU make.]);;
+AC_CACHE_CHECK(for SA_RESTART, make_cv_sa_restart, [
+ AC_TRY_COMPILE([#include <signal.h>],
+ [return SA_RESTART;],
+ make_cv_sa_restart=yes,
+ make_cv_sa_restart=no)])
+if test "$make_cv_sa_restart" != no; then
+ AC_DEFINE(HAVE_SA_RESTART, 1,
+ [Define if <signal.h> defines the SA_RESTART constant.])
+fi
+
+case "$ac_cv_func_pipe/$ac_cv_func_sigaction/$make_cv_sa_restart/$has_wait_nohang/$make_cv_job_server" in
+ yes/yes/yes/yes/yes)
+ AC_DEFINE(MAKE_JOBSERVER, 1,
+ [Define this to enable job server support in GNU make.]);;
esac
dnl Allow building with dmalloc