summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2000-06-14 22:29:30 +0000
committerPaul Smith <psmith@gnu.org>2000-06-14 22:29:30 +0000
commitc392c19335891fddcb446e63cbe6aa43b4f4b3a2 (patch)
tree66e404c5960982bf12ea81ee50ac6b545301e976 /configure.in
parent4972b017b63f3ce324bfa65a1b46a2a173baf463 (diff)
downloadgunmake-c392c19335891fddcb446e63cbe6aa43b4f4b3a2.tar.gz
* More fixes for configuring gettext correctly.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 37a755b..97c2874 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,7 @@ AC_REVISION([$Id$])
AC_PREREQ(2.13)dnl dnl Minimum Autoconf version required.
AC_INIT(vpath.c)dnl dnl A distinctive file to look for in srcdir.
-AM_INIT_AUTOMAKE(make, 3.79.1)
+AM_INIT_AUTOMAKE(make, 3.79.0.1)
AM_CONFIG_HEADER(config.h)
dnl Regular configure stuff
@@ -43,7 +43,7 @@ AC_HEADER_TIME
dnl Handle internationalization
ALL_LINGUAS="de es fr ja ko nl pl pt_BR ru"
-fp_WITH_GETTEXT
+pds_WITH_GETTEXT
AC_STRUCT_ST_MTIM_NSEC
jm_AC_TYPE_UINTMAX_T
@@ -133,7 +133,7 @@ pid = waitpid (-1, &status, 0);
],
[make_cv_union_wait=yes], [make_cv_union_wait=no])])
if test "$make_cv_union_wait" = yes; then
- AC_DEFINE(HAVE_UNION_WAIT)
+ AC_DEFINE(HAVE_UNION_WAIT, 1, [Define this if you have the \`union wait' type in <sys/wait.h>.])
fi
AC_MSG_RESULT($make_cv_union_wait)
@@ -177,7 +177,8 @@ case "$ac_cv_func_waitpid/$ac_cv_func_wait3" in
esac
case "$ac_cv_func_pipe/$ac_cv_func_sigaction/$has_wait_nohang/$make_cv_job_server" in
- yes/yes/yes/yes) AC_DEFINE(MAKE_JOBSERVER) ;;
+ yes/yes/yes/yes) AC_DEFINE(MAKE_JOBSERVER, 1,
+ [Define this to enable job server support in GNU make.]);;
esac
dnl Allow building with dmalloc
@@ -213,7 +214,8 @@ if ( /usr/sccs/admin -n s.conftest || admin -n s.conftest ) >/dev/null 2>&1 &&
make_cv_sys_get_minus_G=no
fi])
case "$make_cv_sys_get_minus_G" in
- yes) AC_DEFINE(SCCS_GET_MINUS_G);;
+ yes) AC_DEFINE(SCCS_GET_MINUS_G, 1,
+ [Define this if the SCCS \`get' command understands the \`-G<file>' option.]);;
esac
fi
rm -f s.conftest conftoast