summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2002-09-10 07:27:28 +0000
committerPaul Smith <psmith@gnu.org>2002-09-10 07:27:28 +0000
commit7ea029a07c02b9401cb3d88566eac41959b84c11 (patch)
tree0a26e865bee26f79c718258415b5389023076942 /configure.in
parent9b41488ad15e4ffc63b8094379c17f567b094c1b (diff)
downloadgunmake-7ea029a07c02b9401cb3d88566eac41959b84c11.tar.gz
Add support for broken SA_RESTART on PTX.
Fix bug #103: allow ifdef, export, and unexport to expand their arguments.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5abbad5..c5c8026 100644
--- a/configure.in
+++ b/configure.in
@@ -291,6 +291,21 @@ make_cv_sys_gnu_glob=no])])
# Tell automake about this, so it can build the right .c files.
AM_CONDITIONAL(USE_LOCAL_GLOB, test "$make_cv_sys_gnu_glob" = no)
+# PTX systems have a broken implementation of SA_RESTART. I know of
+# no way to test for this behavior, so I'll just test for PTX
+
+case "$host" in
+ i386-sequent-sysv4)
+ AC_DEFINE(HAVE_BROKEN_RESTART, 1, [This system has SA_RESTART, but it doesn't work properly.])
+ echo ""
+ echo "WARNING: The SA_RESTART sigaction() flag does not work on PTX."
+ echo " This causes 'make -j' to fail at random times."
+ echo " I am installing a workaround, which is mostly but not 100%"
+ echo " effective. If you see random failures during 'make -j'"
+ echo " you should either contact the bug list, or not use -j."
+ echo "" ;;
+esac
+
# Let the makefile know what our build host is
AC_DEFINE_UNQUOTED(MAKE_HOST,"$host",[Build host information.])