summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2013-05-06 00:22:27 -0400
committerPaul Smith <psmith@gnu.org>2013-05-06 00:22:27 -0400
commit94735f0ad7f67c56afa1513381c73e8f62cd44fc (patch)
treefe07174cab4eba5d50ee5ad04684cfee6e454b08 /configure.ac
parent7c77486d1fbc820e6db97a5a11fabdc34dbdb729 (diff)
downloadgunmake-94735f0ad7f67c56afa1513381c73e8f62cd44fc.tar.gz
Remove use of vfork().
GCC was giving us warnings, most OS's now just run fork() when you call vfork(), and looking at the standard definition of vfork() we are a long way from using it safely anyway: you're not allowed to even call a function before you exec().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 45b201c..7b70f04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,7 +153,6 @@ AC_CHECK_FUNCS([strcasecmp strncasecmp strcmpi strncmpi stricmp strnicmp])
AC_FUNC_STRCOLL
AC_FUNC_ALLOCA
-AC_FUNC_FORK([])
AC_FUNC_CLOSEDIR_VOID
# See if the user wants to add (or not) GNU Guile support