summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2014-09-14 01:03:19 -0400
committerPaul Smith <psmith@gnu.org>2014-09-14 01:03:19 -0400
commit7f9ce6e97bd1bb4289477ac76532e156947e7865 (patch)
treeb3e06143fcb0801ff26f203351b5037b5ecbd92f /configure.ac
parent621e9edfe9ac4ad20ce297787fa308b032b3fa8e (diff)
downloadgunmake-7f9ce6e97bd1bb4289477ac76532e156947e7865.tar.gz
* main.c (main): Set MAKE_TTYOUT and MAKE_TTYERR.
* configure.ac: Test for isatty() and ttyname() * makeint.h: provide a substitute for ttyname() if it's not available. * config.ami.template, config.h-vms.template, config.h.W32.template: define/undefine HAVE_ISATTY/HAVE_TTYNAME macros. * NEWS, doc/make.texi: Document these new variables.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 59333d1..97fd090 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,7 +140,7 @@ AC_CHECK_FUNCS([strdup strndup mkstemp mktemp fdopen fileno \
dup dup2 getcwd realpath sigsetmask sigaction \
getgroups seteuid setegid setlinebuf setreuid setregid \
getrlimit setrlimit setvbuf pipe strerror strsignal \
- lstat readlink atexit])
+ lstat readlink atexit isatty ttyname])
# We need to check declarations, not just existence, because on Tru64 this
# function is not declared without special flags, which themselves cause