summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2013-04-28 17:59:28 -0400
committerPaul Smith <psmith@gnu.org>2013-04-28 17:59:28 -0400
commit441b64335590ab91854b997bec07a9578086d895 (patch)
tree1ef33d76f43c79d7e0effcc0177625054a35d591 /configure.ac
parent8b034b7d18a08d3a2378e5b6fc9fbdd1b658f142 (diff)
downloadgunmake-441b64335590ab91854b997bec07a9578086d895.tar.gz
Remove support for pre-ANSI variadic function calls.
We've required support for ANSI C (ISO C 89) or better for quite a while. Get rid of the old varags.h, doprnt() stuff and simply assume ANSI C variadic function capability and basic C runtime library support (vfprintf, vsprintf, etc.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 0 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2ba81ad..d610343 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,10 +70,6 @@ AS_IF([test "$ac_cv_prog_cc_stdc" != no],
[Define to 1 if your compiler conforms to the ANSI C standard.])
])
-
-# Determine what kind of variadic function calls we support
-AC_CHECK_HEADERS([stdarg.h varargs.h], [break])
-
AM_PROG_CC_C_O
AC_C_CONST
AC_TYPE_SIGNAL
@@ -164,7 +160,6 @@ AC_FUNC_STRCOLL
AC_FUNC_ALLOCA
AC_FUNC_FORK([])
-AC_FUNC_VPRINTF
AC_FUNC_CLOSEDIR_VOID
# See if the user wants to add (or not) GNU Guile support