summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>1999-03-30 06:19:17 +0000
committerPaul Smith <psmith@gnu.org>1999-03-30 06:19:17 +0000
commite005a48b9fbbe7aea8013f887467714c6cf40fbe (patch)
tree2ce8d68c0d2e8c91acb4714129f3e81402f2fdfd /Makefile.am
parent0798a611694e3557450446f5c38049ddac4d0cbb (diff)
downloadgunmake-e005a48b9fbbe7aea8013f887467714c6cf40fbe.tar.gz
* More build fixes. I think a vanilla CVS checkout should build OK now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index caf555e..d3eafc6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,9 +17,7 @@ man_MANS = make.1
INCLUDES = -DLIBDIR=\"$(libdir)\" -DINCLUDEDIR=\"$(includedir)\"
-BUILT_SOURCES = README build.sh.in
-
-EXTRA_DIST = $(BUILT_SOURCES) $(man_MANS) README.customs remote-cstms.c\
+EXTRA_DIST = README build.sh.in $(man_MANS) README.customs remote-cstms.c\
make-stds.texi texinfo.tex SCOPTIONS SMakefile\
README.Amiga Makefile.ami config.ami make.lnk amiga.c amiga.h\
README.DOS Makefile.DOS configure.bat dosbuild.bat configh.dos\
@@ -33,6 +31,13 @@ MOSTLYCLEANFILES = loadavg.c
CLEANFILES = loadavg
+# --------------- Local BUILD Section
+
+build.sh: $(top_builddir)/config.status $(srcdir)/build.sh.in
+ cd $(top_builddir) \
+ && CONFIG_FILES=build.sh.in CONFIG_HEADERS= $(SHELL) ./config.status
+
+
# --------------- Local INSTALL Section
# If necessary, change the gid of the app and turn on the setgid flag.
@@ -125,6 +130,12 @@ check-regression: all
cd $$testdir && ./run_make_tests -make $$here/make $(MAKETESTFLAGS)
+# --------------- Local CLEAN section
+
+maintainer-clean-local:
+ -test -z "$(MAINTAINERCLEANFILES)" || rm -f $(MAINTAINERCLEANFILES)
+
+
# --------------- Maintainer's Section
@MAINT_MAKEFILE@