summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>1999-02-19 18:07:49 +0000
committerPaul Smith <psmith@gnu.org>1999-02-19 18:07:49 +0000
commit84f38c9c6f56c7056a1d1a5abf9151bf15760151 (patch)
treee1b51c8fb565ac9c6e098e4d7bc932b43b93925d /Makefile.am
parent58085071441553b34ad1b06cd3f328bc15705383 (diff)
downloadgunmake-84f38c9c6f56c7056a1d1a5abf9151bf15760151.tar.gz
* Updates for automake 1.4 and autoconf 2.13
* Check for a libc version of GNU glob and, if found, don't use the local glob headers. * Fix a bug in OpenVMS archive handling. * Fix a bug in VMS siglist processing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ab1c1f1..3bfaf47 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,7 @@ make_LDADD = @LIBOBJS@ @ALLOCA@ glob/libglob.a
info_TEXINFOS = make.texinfo
man_MANS = make.1
-INCLUDES = -I$(srcdir)/glob -DLIBDIR=\"$(libdir)\" -DINCLUDEDIR=\"$(includedir)\"
+INCLUDES = -DLIBDIR=\"$(libdir)\" -DINCLUDEDIR=\"$(includedir)\"
BUILT_SOURCES = README build.sh.in
@@ -130,5 +130,7 @@ check-regression: all
if MAINT_MAKEFILE
# Note this requires GNU make. Not to worry, since it will only be included
# in the Makefile if we're in the maintainer's environment.
-include $(srcdir)/maintMakefile
+# Ulp! Need a leading space to "hide" this include from automake's new (in
+# 1.4) include feature :(
+ include $(srcdir)/maintMakefile
endif