summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>1997-08-18 18:11:04 +0000
committerPaul Smith <psmith@gnu.org>1997-08-18 18:11:04 +0000
commit63dff1e0bcb9e1bdd189e4a3e0d6126389251885 (patch)
treef8b39c21a6c709622d4fcc18f40539477a5ceb1a /Makefile.am
parente746a9c9510b2cc83548e8d9108eb24540e7a821 (diff)
downloadgunmake-63dff1e0bcb9e1bdd189e4a3e0d6126389251885.tar.gz
Bug fixes and automake changes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6960f08
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,63 @@
+# -*-Makefile-*-, or close enough
+
+AUTOMAKE_OPTIONS = 1.2
+
+bin_PROGRAMS = make
+
+make_SOURCES = main.c commands.c job.c dir.c file.c misc.c read.c remake.c \
+ rule.c implicit.c default.c variable.c expand.c function.c \
+ vpath.c version.c ar.c arscan.c remote-$(REMOTE).c \
+ commands.h dep.h filedef.h job.h make.h rule.h variable.h \
+ signame.c signame.h \
+ getopt.c getopt1.c getopt.h
+make_LDADD = @LIBOBJS@ @ALLOCA@ glob/libglob.a
+
+info_TEXINFOS = make.texinfo
+
+INCLUDES = -I$(srcdir)/glob -DLIBDIR=\"$(libdir)\" -DINCLUDEDIR=\"$(includedir)\"
+
+BUILT_SOURCES = README build.sh.in
+
+EXTRA_DIST = make.man $(BUILT_SOURCES) remote-cstms.c \
+ make-stds.texi texinfo.tex SCOPTIONS SMakefile \
+ Makefile.ami README.Amiga config.ami amiga.c amiga.h \
+ NMakefile README.DOS configh.dos configure.bat makefile.com \
+ README.W32 build_w32.bat config.h.W32 subproc.bat make.lnk \
+ config.h-vms makefile.vms readme.vms vmsdir.h vmsfunctions.c \
+ vmsify.c
+
+SUBDIRS = glob
+
+# Look for the make test suite, and run it if found. Look in MAKE_TEST, or
+# in the srcdir and its parent and the distdir and its parent.
+#
+check-local:
+ @here=`pwd`; test=""; \
+ case "$(MAKE_TEST)" in "") \
+ for d1 in $$here $(srcdir); do \
+ for d2 in .. .; do \
+ try=`ls -1 $$d1/$$d2/make-test-*/run_make_tests 2>/dev/null | tail -1`; \
+ case "$$try" in "") : ;; *) test="$$try" ;; esac; \
+ done; done ;; \
+ *) test="$(MAKE_TEST)" ;; \
+ esac; \
+ case "$$test" in \
+ "") echo "Couldn't find make-test-* test suite."; exit 1;; \
+ esac; \
+ testdir=`dirname $$test`; \
+ echo "cd $$testdir && ./run_make_tests -make_path $$here/make"; \
+ cd $$testdir && ./run_make_tests -make_path $$here/make"
+
+# Install the w32 subdirectory
+#
+dist-hook:
+ (cd $(srcdir); \
+ w32=`find w32 -follow \( -name CVS -prune \) -o -type f -print`; \
+ tar chf - $$w32) \
+ | (cd $(distdir); tar xfBp -)
+
+if MAINT_MAKEFILE
+# Note this requires GNU make. Not to worry, since it will only be included
+# in the Makefile if we're in the maintainer's environment.
+include $(srcdir)/maintMakefile
+endif