summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/control13
-rwxr-xr-xdebian/rules20
-rw-r--r--debian/source/format1
-rw-r--r--debian/windows10-icons.install11
5 files changed, 50 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3d4d109
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+windows10-icons (2020.10.18.git.9f199c6-0pin1) unstable; urgency=medium
+
+ * Initial release.
+
+ -- Igor Pashev <pashev.igor@gmail.com> Thu, 08 Dec 2022 11:53:12 +0200
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..c9422e4
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,13 @@
+Source: windows10-icons
+Homepage: https://github.com/B00merang-Artwork/Windows-10
+Section: misc
+Priority: extra
+Maintainer: Igor Pashev <pashev.igor@gmail.com>
+Build-Depends: debhelper-compat (= 13)
+
+
+Package: windows10-icons
+Architecture: all
+Depends: ${misc:Depends}
+Description: Windows10 icons
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c6c82fb
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+GIT_REPO := https://github.com/B00merang-Artwork/Windows-10.git
+DEBIAN_PATH := $(abspath $(dir $(firstword $(MAKEFILE_LIST))))
+PACKAGE := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Source:/ {print $$2}')
+SRC_VERSION := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
+GIT_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+git\.(\w+).*,\1,')
+TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
+.PHONY: get-orig-source
+get-orig-source:
+ rm -rf get-orig-source $(TARBALL) && mkdir get-orig-source
+ git clone $(GIT_REPO) get-orig-source/$(PACKAGE)-$(SRC_VERSION)
+ git -C get-orig-source/$(PACKAGE)-$(SRC_VERSION) checkout $(GIT_REVISION)
+ find get-orig-source/$(PACKAGE)-$(SRC_VERSION) -name '.*' -print0 | xargs -0 --no-run-if-empty rm -rfv
+ tar cJf $(TARBALL) -C get-orig-source $(PACKAGE)-$(SRC_VERSION)
+ rm -rf get-orig-source
+ @echo " "$(TARBALL)" created; move it to the right destination to build the package"
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/windows10-icons.install b/debian/windows10-icons.install
new file mode 100644
index 0000000..14be9f5
--- /dev/null
+++ b/debian/windows10-icons.install
@@ -0,0 +1,11 @@
+8x8 /usr/share/icons/Windows10
+16x16 /usr/share/icons/Windows10
+22x22 /usr/share/icons/Windows10
+24x24 /usr/share/icons/Windows10
+32x32 /usr/share/icons/Windows10
+48x48 /usr/share/icons/Windows10
+128x128 /usr/share/icons/Windows10
+256x256 /usr/share/icons/Windows10
+512x512 /usr/share/icons/Windows10
+scalable /usr/share/icons/Windows10
+index.theme /usr/share/icons/Windows10