summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2013-10-31 16:56:54 +0400
committerIgor Pashev <pashev.igor@gmail.com>2013-10-31 16:56:54 +0400
commit41795de27021003eea72e7aed038beb260398a14 (patch)
treec77d9b8d9dc20af041a24042d6716799b2e4f02a /debian/rules
parent0c87e16daa02e715ff82b390c3429177b5ef9009 (diff)
downloadopen-axiom-debian-41795de27021003eea72e7aed038beb260398a14.tar.gz
Fixed get-orig-source target to work out of source tree
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c9c2648..2ec1007 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,8 @@ oa_libdir := /usr/lib/open-axiom
PACKAGE := open-axiom
SVN_REPO := svn://svn.code.sf.net/p/open-axiom/code/trunk
-SRC_VERSION := $(shell dpkg-parsechangelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
+DEBIAN_PATH := $(abspath $(dir $(firstword $(MAKEFILE_LIST))))
+SRC_VERSION := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
SVN_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+svn([0-9]+),\1,')
TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
.PHONY: get-orig-source