summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules49
1 files changed, 49 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e31ccb2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,49 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/buildflags.mk
+include /usr/share/dpkg/architecture.mk
+
+LIBDIR := lib/$(DEB_HOST_MULTIARCH)/freebasic
+BUILD_FBC := fbc
+OPTIONS := prefix=/usr libdir=$(LIBDIR)
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ make V=1 CFLAGS="$(CFLAGS)" $(OPTIONS) FBC='$(BUILD_FBC)'
+
+override_dh_auto_install:
+ make V=1 DESTDIR=$(CURDIR)/debian/tmp $(OPTIONS) install
+
+override_dh_auto_clean:
+ make $(OPTIONS) clean
+ make -C tests $(OPTIONS) clean
+
+override_dh_auto_test:
+ make -C tests $(OPTIONS) FBC="$(CURDIR)/bin/fbc -i $(CURDIR)/inc" unit-tests
+
+override_dh_compress:
+ dh_compress -X /examples/
+
+GIT_REPO := https://github.com/freebasic/fbc
+DEBIAN_PATH := $(abspath $(dir $(firstword $(MAKEFILE_LIST))))
+PACKAGE := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Source:/ {print $$2}')
+SRC_VERSION := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
+GIT_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+git\.(\w+).*,\1,')
+TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
+DELETE := \
+ contrib \
+ doc/build-win32.bat
+.PHONY: get-orig-source
+get-orig-source:
+ rm -rf get-orig-source $(TARBALL) && mkdir get-orig-source
+ git clone $(GIT_REPO) get-orig-source/$(PACKAGE)-$(SRC_VERSION)
+ git -C get-orig-source/$(PACKAGE)-$(SRC_VERSION) checkout $(GIT_REVISION)
+ find get-orig-source/$(PACKAGE)-$(SRC_VERSION) -name '.*' -print0 | xargs -0 --no-run-if-empty rm -rfv
+ cd get-orig-source/$(PACKAGE)-$(SRC_VERSION) && \
+ rm -rfv $(DELETE) && \
+ echo "FBVERSION := $(SRC_VERSION)" > version.mk
+ tar cJf $(TARBALL) -C get-orig-source $(PACKAGE)-$(SRC_VERSION)
+ rm -rf get-orig-source
+ @echo " "$(TARBALL)" created; move it to the right destination to build the package"