summaryrefslogtreecommitdiff
path: root/sci-libs/cuba/cuba-3.0-r1.ebuild
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2012-07-22 13:22:18 +0400
committerIgor Pashev <pashev.igor@gmail.com>2012-07-22 13:22:18 +0400
commite303376fdcec6942f3f920b2af1d37579b8e1d00 (patch)
tree4943878fe9997701397d4616007441267a6534b3 /sci-libs/cuba/cuba-3.0-r1.ebuild
parent2114044825a17fa3fc65e4216261f1e8212e7ffa (diff)
downloadebuilds-e303376fdcec6942f3f920b2af1d37579b8e1d00.tar.gz
New upstream version. Removed shared library support. Removed cuba-2.1-r1.ebuild and cuba-3.0.ebuild
Diffstat (limited to 'sci-libs/cuba/cuba-3.0-r1.ebuild')
-rw-r--r--sci-libs/cuba/cuba-3.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/cuba/cuba-3.0-r1.ebuild b/sci-libs/cuba/cuba-3.0-r1.ebuild
new file mode 100644
index 0000000..c1a0805
--- /dev/null
+++ b/sci-libs/cuba/cuba-3.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="A library for multidimensional numerical integration"
+HOMEPAGE="http://www.feynarts.de/cuba/"
+LICENSE="LGPL"
+SRC_URI="http://www.feynarts.de/cuba/Cuba-${PV}.tar.gz"
+S=${WORKDIR}/Cuba-${PV}
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+SLOT="0"
+
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+ emake lib || die "emake failed"
+ else
+ die "No Makefile"
+ fi
+}
+
+#src_test() {
+# emake check
+#}
+
+
+src_install() {
+ dolib.a libcuba.a
+ use doc && dodoc cuba.pdf ChangeLog
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demo
+ fi
+ insinto /usr/include
+ doins cuba.h
+}
+