summaryrefslogtreecommitdiff
path: root/openssl0.9.8/patches/pkg-config.patch
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-26 17:19:15 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-26 17:19:15 +0400
commita5fa80e2a069e35331af10369d810b4daa63635b (patch)
treecde72d630e4066581f9818b3a506b6433e343923 /openssl0.9.8/patches/pkg-config.patch
parenta66434a8c8bc288d863e0f649e8e465ac4525043 (diff)
downloadcibs-pkgs-a5fa80e2a069e35331af10369d810b4daa63635b.tar.gz
openssl 0.9.8 mostly done
Diffstat (limited to 'openssl0.9.8/patches/pkg-config.patch')
-rw-r--r--openssl0.9.8/patches/pkg-config.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/openssl0.9.8/patches/pkg-config.patch b/openssl0.9.8/patches/pkg-config.patch
new file mode 100644
index 0000000..38923b0
--- /dev/null
+++ b/openssl0.9.8/patches/pkg-config.patch
@@ -0,0 +1,34 @@
+Index: openssl-0.9.8k/Makefile.org
+===================================================================
+--- openssl-0.9.8k.orig/Makefile.org 2009-07-19 11:34:56.000000000 +0200
++++ openssl-0.9.8k/Makefile.org 2009-07-19 11:36:02.000000000 +0200
+@@ -444,7 +444,8 @@
+ echo 'Description: OpenSSL cryptography library'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lcrypto'; \
++ echo 'Libs.private: $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libcrypto.pc
+
+ libssl.pc: Makefile
+@@ -457,7 +458,8 @@
+ echo 'Description: Secure Sockets Layer and cryptography libraries'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lssl'; \
++ echo 'Libs.private: -lcrypto $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libssl.pc
+
+ openssl.pc: Makefile
+@@ -470,7 +472,8 @@
+ echo 'Description: Secure Sockets Layer and cryptography libraries and tools'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
++ echo 'Libs.private: $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
+
+ Makefile: Makefile.org Configure config