summaryrefslogtreecommitdiff
path: root/ncurses/Makefile
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-11-20 17:07:10 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-11-20 17:07:10 +0400
commitcec5d5148ce7a89d9ee2d14def1a6376e64831a8 (patch)
tree02b2e539d9d862b3f5cd0b2010a0debf62bf4769 /ncurses/Makefile
parent9df1de5fc699da6b9623d7dba0a21d3a27f29897 (diff)
downloadcibs-pkgs-cec5d5148ce7a89d9ee2d14def1a6376e64831a8.tar.gz
ncurses (library and main terminfo)
Diffstat (limited to 'ncurses/Makefile')
-rw-r--r--ncurses/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/ncurses/Makefile b/ncurses/Makefile
new file mode 100644
index 0000000..2eebd95
--- /dev/null
+++ b/ncurses/Makefile
@@ -0,0 +1,53 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/patch.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
+include /usr/share/cibs/rules/64.mk
+
+summary := The new curses library
+license := MIT, BSD
+license-file := ncurses.license
+
+name := ncurses
+home := http://invisible-island.net/$(name)
+version := 5.9
+archive := $(name)-$(version).tar.gz
+download := ftp://invisible-island.net/$(name)/$(archive)
+checksum := \
+ md5:8cb9c412e5f2d96bc6f459aa8c6282a1 \
+ sha1:3e042e5f2c7223bffdaac9646a533b8c758b65b5 \
+ sha256:9046298fb440324c9d4135ecea7879ffed8546dd1b58e59430ea07a4633f563b \
+ size:2826473
+
+configure-options += \
+ --with-shared \
+ --without-profile \
+ --without-debug \
+ --disable-rpath \
+ --enable-echo \
+ --enable-const \
+ --enable-pc-files \
+ --without-ada \
+ --without-tests \
+ --enable-symlinks \
+ --disable-lp64 \
+ --with-chtype='long' \
+ --with-mmask-t='long' \
+ --disable-termcap \
+ --with-default-terminfo-dir=/etc/terminfo \
+ --with-terminfo-dirs="/etc/terminfo:/lib/terminfo:/usr/share/terminfo" \
+ --with-ticlib=tic \
+ --with-termlib=tinfo
+
+configure-env.32 = \
+ PKG_CONFIG_LIBDIR="$(libdir.32)/pkgconfig"
+configure-options.32 = \
+ --without-manpages \
+ --without-progs
+
+configure-env.64 = \
+ PKG_CONFIG_LIBDIR="$(libdir.64)/pkgconfig"
+configure-options.64 = \
+ --with-progs
+