summaryrefslogtreecommitdiff
path: root/mpfr
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
commit98cb3b26f4043c9a83029c21855ff61b7601e611 (patch)
treee0e08eb9e6a168c65444dfc9751a522cb08b0ab3 /mpfr
downloadcibs-pkgs-98cb3b26f4043c9a83029c21855ff61b7601e611.tar.gz
Initial commit from cibs/examples
Diffstat (limited to 'mpfr')
-rw-r--r--mpfr/Makefile24
-rw-r--r--mpfr/mpfr.p5m26
2 files changed, 50 insertions, 0 deletions
diff --git a/mpfr/Makefile b/mpfr/Makefile
new file mode 100644
index 0000000..cde4099
--- /dev/null
+++ b/mpfr/Makefile
@@ -0,0 +1,24 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
+include /usr/share/cibs/rules/64.mk
+
+summary := GNU library for multiple-precision floating-point computations with correct rounding
+license := LGPLv3
+license-file := COPYING.LESSER
+
+build-depends += \
+ pkg:/library/gmp \
+ pkg:/compress/xz \
+
+name := mpfr
+home := http://www.mpfr.org/
+version := 3.1.1
+archive := $(name)-$(version).tar.xz
+download := http://ftp.gnu.org/gnu/$(name)/$(archive)
+checksum := \
+ md5:91d51c41fcf2799e4ee7a7126fc95c17 \
+ sha1:7527c322b91fe8e6055ead551e1b46b9f1712ccd \
+ sha256:49d5acc32dbeec30a8e26af9c19845763d63feacb8bf97b12876008419f5a17a \
+ size:1071688
diff --git a/mpfr/mpfr.p5m b/mpfr/mpfr.p5m
new file mode 100644
index 0000000..202bbd7
--- /dev/null
+++ b/mpfr/mpfr.p5m
@@ -0,0 +1,26 @@
+set name=pkg.fmri value=pkg:/library/$(name)@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+dir path=usr
+dir path=usr/include
+dir path=usr/lib
+dir path=usr/lib/$(MACH64)
+dir path=usr/share
+dir path=usr/share/info
+file path=usr/include/mpf2mpfr.h
+file path=usr/include/mpfr.h
+file path=usr/lib/$(MACH64)/libmpfr.so.4.1.1
+file path=usr/lib/libmpfr.so.4.1.1
+file path=usr/share/info/mpfr.info
+link path=usr/lib/$(MACH64)/libmpfr.so target=libmpfr.so.4.1.1
+link path=usr/lib/$(MACH64)/libmpfr.so.4 target=libmpfr.so.4.1.1
+link path=usr/lib/libmpfr.so target=libmpfr.so.4.1.1
+link path=usr/lib/libmpfr.so.4 target=libmpfr.so.4.1.1
+
+# Transitional links:
+link path=usr/lib/libmpfr.so.1 target=libmpfr.so.4
+link path=usr/lib/$(MACH64)/libmpfr.so.1 target=libmpfr.so.4