summaryrefslogtreecommitdiff
path: root/libtool
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
commit98cb3b26f4043c9a83029c21855ff61b7601e611 (patch)
treee0e08eb9e6a168c65444dfc9751a522cb08b0ab3 /libtool
downloadcibs-pkgs-98cb3b26f4043c9a83029c21855ff61b7601e611.tar.gz
Initial commit from cibs/examples
Diffstat (limited to 'libtool')
-rw-r--r--libtool/Makefile22
-rw-r--r--libtool/libltdl.p5m57
-rw-r--r--libtool/libtool.p5m56
-rw-r--r--libtool/patches/bootstrap-no-go.patch12
4 files changed, 147 insertions, 0 deletions
diff --git a/libtool/Makefile b/libtool/Makefile
new file mode 100644
index 0000000..db1a2ac
--- /dev/null
+++ b/libtool/Makefile
@@ -0,0 +1,22 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/patch.mk
+include /usr/share/cibs/rules/autoreconf.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
+include /usr/share/cibs/rules/64.mk
+
+summary := Generic library support script
+license := GPL
+license-file := COPYING
+
+home := http://www.gnu.org/software/libtool/
+name := libtool
+version := 2.4.2
+archive := $(name)-$(version).tar.gz
+download := http://ftp.gnu.org/gnu/$(name)/$(archive)
+checksum := \
+ md5:d2f3b7d4627e69e13514a40e72a24d50 \
+ sha1:22b71a8b5ce3ad86e1094e7285981cae10e6ff88 \
+ sha256:b38de44862a987293cd3d8dfae1c409d514b6c4e794ebc93648febf9afc38918 \
+ size:2632347
diff --git a/libtool/libltdl.p5m b/libtool/libltdl.p5m
new file mode 100644
index 0000000..6f2d8d4
--- /dev/null
+++ b/libtool/libltdl.p5m
@@ -0,0 +1,57 @@
+set name=pkg.fmri value=pkg:/library/libtool/libltdl@$(ips-version)
+set name=pkg.summary value="A system independent dlopen wrapper for GNU libtool"
+set name=info.upstream-url value="$(home)"
+set name=info.source_url value="$(download)"
+
+<transform dir file link path=.*/share/libtool/libltdl.* -> default facet.devel true>
+
+license libltdl/COPYING.LIB license=LGPL
+
+dir path=usr/share/libtool/libltdl
+dir path=usr/share/libtool/libltdl/libltdl
+dir path=usr/share/libtool/libltdl/loaders
+dir path=usr/include/libltdl
+file path=usr/share/libtool/libltdl/README
+file path=usr/share/libtool/libltdl/slist.c
+file path=usr/share/libtool/libltdl/Makefile.inc
+file path=usr/share/libtool/libltdl/lt__alloc.c
+file path=usr/share/libtool/libltdl/lt_dlloader.c
+file path=usr/share/libtool/libltdl/lt__dirent.c
+file path=usr/share/libtool/libltdl/aclocal.m4
+file path=usr/share/libtool/libltdl/argz_.h
+file path=usr/share/libtool/libltdl/configure.ac
+file path=usr/share/libtool/libltdl/configure
+file path=usr/share/libtool/libltdl/libltdl/lt__private.h
+file path=usr/share/libtool/libltdl/libltdl/lt_system.h
+file path=usr/share/libtool/libltdl/libltdl/lt__alloc.h
+file path=usr/share/libtool/libltdl/libltdl/lt_error.h
+file path=usr/share/libtool/libltdl/libltdl/lt__glibc.h
+file path=usr/share/libtool/libltdl/libltdl/lt__dirent.h
+file path=usr/share/libtool/libltdl/libltdl/lt__strl.h
+file path=usr/share/libtool/libltdl/libltdl/lt_dlloader.h
+file path=usr/share/libtool/libltdl/libltdl/slist.h
+file path=usr/share/libtool/libltdl/lt_error.c
+file path=usr/share/libtool/libltdl/ltdl.h
+file path=usr/share/libtool/libltdl/lt__strl.c
+file path=usr/share/libtool/libltdl/argz.c
+file path=usr/share/libtool/libltdl/Makefile.in
+file path=usr/share/libtool/libltdl/ltdl.c
+file path=usr/share/libtool/libltdl/Makefile.am
+file path=usr/share/libtool/libltdl/config-h.in
+file path=usr/share/libtool/libltdl/loaders/load_add_on.c
+file path=usr/share/libtool/libltdl/loaders/preopen.c
+file path=usr/share/libtool/libltdl/loaders/dlopen.c
+file path=usr/share/libtool/libltdl/loaders/dld_link.c
+file path=usr/share/libtool/libltdl/loaders/shl_load.c
+file path=usr/share/libtool/libltdl/loaders/dyld.c
+file path=usr/share/libtool/libltdl/loaders/loadlibrary.c
+file path=usr/share/libtool/libltdl/COPYING.LIB
+file path=usr/include/libltdl/lt_system.h
+file path=usr/include/libltdl/lt_dlloader.h
+file path=usr/include/libltdl/lt_error.h
+file path=usr/lib/libltdl.so.7.1.1
+link path=usr/lib/libltdl.so.7 target=libltdl.so.7.1.1
+link path=usr/lib/libltdl.so target=libltdl.so.7.1.1
+file path=usr/lib/$(MACH64)/libltdl.so.7.1.1
+link path=usr/lib/$(MACH64)/libltdl.so.7 target=libltdl.so.7.1.1
+link path=usr/lib/$(MACH64)/libltdl.so target=libltdl.so.7.1.1
diff --git a/libtool/libtool.p5m b/libtool/libtool.p5m
new file mode 100644
index 0000000..6c9e397
--- /dev/null
+++ b/libtool/libtool.p5m
@@ -0,0 +1,56 @@
+#
+# CDDL HEADER START
+#
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License (the "License").
+# You may not use this file except in compliance with the License.
+#
+# You can obtain a copy of the license
+# at http://www.opensource.org/licenses/CDDL-1.0
+# See the License for the specific language governing permissions
+# and limitations under the License.
+#
+# When distributing Covered Code, include this CDDL HEADER in each file.
+# If applicable, add the following below this CDDL HEADER, with the
+# fields enclosed by brackets "[]" replaced with your own identifying
+# information: Portions Copyright [yyyy] [name of copyright owner]
+#
+# CDDL HEADER END
+#
+#
+# Copyright (C) 2012, Nexenta Systems, Inc. All rights reserved.
+#
+
+
+set name=pkg.fmri value=pkg:/developer/build/$(name)@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source_url value="$(download)"
+license $(license-file) license="$(license)"
+
+dir path=usr
+dir path=usr/share
+dir path=usr/share/libtool
+dir path=usr/share/libtool/config
+dir path=usr/share/info
+dir path=usr/share/aclocal
+dir path=usr/bin
+file path=usr/share/libtool/config/config.guess
+file path=usr/share/libtool/config/missing
+file path=usr/share/libtool/config/depcomp
+file path=usr/share/libtool/config/compile
+file path=usr/share/libtool/config/install-sh
+file path=usr/share/libtool/config/ltmain.sh
+file path=usr/share/libtool/config/config.sub
+file path=usr/share/info/libtool.info
+file path=usr/share/info/libtool.info-1
+file path=usr/share/aclocal/ltoptions.m4
+file path=usr/share/aclocal/ltversion.m4
+file path=usr/share/aclocal/lt~obsolete.m4
+file path=usr/share/aclocal/ltdl.m4
+file path=usr/share/aclocal/libtool.m4
+file path=usr/share/aclocal/argz.m4
+file path=usr/share/aclocal/ltsugar.m4
+file path=usr/bin/libtool
+file path=usr/bin/libtoolize
+
diff --git a/libtool/patches/bootstrap-no-go.patch b/libtool/patches/bootstrap-no-go.patch
new file mode 100644
index 0000000..1d8e98a
--- /dev/null
+++ b/libtool/patches/bootstrap-no-go.patch
@@ -0,0 +1,12 @@
+Description: Go is not supported before LT 2.4
+diff -dubr source/configure.ac nogo/configure.ac
+--- source/configure.ac 2011-10-17 14:17:17.000000000 +0400
++++ nogo/configure.ac 2012-10-13 00:29:40.973202656 +0400
+@@ -196,7 +196,6 @@
+ LT_LANG(C++)
+ LT_LANG(Fortran 77)
+ LT_LANG(Fortran)
+-LT_LANG(Go)
+ LT_LANG(Java)
+ LT_LANG(Windows Resource)
+