summaryrefslogtreecommitdiff
path: root/libev
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-31 18:42:25 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-31 18:42:25 +0400
commitb85b1fe55492f0d21077d43fe0de88ba6bbee2e4 (patch)
tree89319db12cd9723f79263f6555c7c93a561f541b /libev
parentbb142d2d628a88011c3fe5d4dcb235c68c09e2aa (diff)
downloadcibs-pkgs-b85b1fe55492f0d21077d43fe0de88ba6bbee2e4.tar.gz
libev
Diffstat (limited to 'libev')
-rw-r--r--libev/Makefile20
-rw-r--r--libev/libev.p5m22
2 files changed, 42 insertions, 0 deletions
diff --git a/libev/Makefile b/libev/Makefile
new file mode 100644
index 0000000..e4553d7
--- /dev/null
+++ b/libev/Makefile
@@ -0,0 +1,20 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/64.mk
+
+summary := high-performance event loop library modelled after libevent
+license := BSD
+license-file := LICENSE
+
+
+name := libev
+home := http://software.schmorp.de/pkg/libev.html
+version := 4.11
+archive := $(name)-$(version).tar.gz
+download := http://dist.schmorp.de/libev/$(archive)
+checksum := \
+ md5:cda69b858a1849dfe6ce17c930cf10cd \
+ sha1:e7752a518742c0f8086a8005aa7efcc4dcf02ed9 \
+ sha256:9f55f16ff6e4d60a1b1fa7f4962af69768468f0d7c362aab6387f52020938cdf \
+ size:484766
diff --git a/libev/libev.p5m b/libev/libev.p5m
new file mode 100644
index 0000000..dc81a50
--- /dev/null
+++ b/libev/libev.p5m
@@ -0,0 +1,22 @@
+set name=pkg.fmri value=pkg:/library/$(name)@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license=$(license)
+
+dir path=usr
+dir path=usr/lib
+dir path=usr/lib/$(mach64)
+dir path=usr/include
+dir path=usr/share
+dir path=usr/share/man
+dir path=usr/share/man/man3
+file path=usr/lib/$(mach64)/libev.so.4.0.0
+file path=usr/include/event.h
+file path=usr/include/ev++.h
+file path=usr/include/ev.h
+file path=usr/share/man/man3/ev.3
+link path=usr/lib/$(mach64)/libev.so target=libev.so.4.0.0
+link path=usr/lib/$(mach64)/libev.so.4 target=libev.so.4.0.0
+