summaryrefslogtreecommitdiff
path: root/gyp/Makefile
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-31 16:39:58 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-31 16:39:58 +0400
commit5806b415e14a73d87a4d72a1f4567fd2d7e24c1a (patch)
treed4568730688bf1f5765540e00ca967571af44229 /gyp/Makefile
parentfbcb6172ef51ac8dc40486bed6006e912f561982 (diff)
downloadcibs-pkgs-5806b415e14a73d87a4d72a1f4567fd2d7e24c1a.tar.gz
Added gyp
Diffstat (limited to 'gyp/Makefile')
-rw-r--r--gyp/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/gyp/Makefile b/gyp/Makefile
new file mode 100644
index 0000000..8033e98
--- /dev/null
+++ b/gyp/Makefile
@@ -0,0 +1,41 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/copy.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/noarch.mk
+
+# This must be rewritten to support
+# multiple pythons and SVN.
+
+summary := Generate Your Projects
+license := BSD
+license-file := LICENSE
+version := 0.1~svn1395
+ips-version := 0.1.0.1395
+name := gyp
+home := http://code.google.com/p/gyp/
+
+build-depends += \
+ pkg:/runtime/python
+
+archive := gyp_0.1~svn1395.orig.tar.gz
+download := http://ftp.de.debian.org/debian/pool/main/g/gyp/$(archive)
+checksum := \
+ md5:512dd02cdba611a94909812a086e1105 \
+ sha1:1a02f725ceb642186d6a62472226125610181175 \
+ sha256:51f116574a8226bfab2946fe054ba0103ac5d470e8e9309cc1333b9c5d6088d3 \
+ size:399588
+
+configure-%-stamp: pre-configure-stamp
+ touch $@
+
+build-%-stamp: configure-%-stamp
+ cd $(builddir) && python setup.py build
+ touch $@
+
+install-%-stamp: build-%-stamp
+ cd $(builddir) && python2.6 setup.py install --root="$(protodir)" \
+ --install-lib=/usr/lib/python2.6/vendor-packages
+ gsed -i 's,#!.*,#!/usr/bin/python2.6,' $(protodir)/usr/bin/gyp
+ touch $@
+
+