summaryrefslogtreecommitdiff
path: root/gmp
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
commit98cb3b26f4043c9a83029c21855ff61b7601e611 (patch)
treee0e08eb9e6a168c65444dfc9751a522cb08b0ab3 /gmp
downloadcibs-pkgs-98cb3b26f4043c9a83029c21855ff61b7601e611.tar.gz
Initial commit from cibs/examples
Diffstat (limited to 'gmp')
-rw-r--r--gmp/Makefile28
-rw-r--r--gmp/gmp.p5m30
-rw-r--r--gmp/gmpxx.p5m20
3 files changed, 78 insertions, 0 deletions
diff --git a/gmp/Makefile b/gmp/Makefile
new file mode 100644
index 0000000..eec700f
--- /dev/null
+++ b/gmp/Makefile
@@ -0,0 +1,28 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
+include /usr/share/cibs/rules/64.mk
+
+summary := GNU library for arbitrary precision arithmetic
+license := LGPLv3
+license-file := COPYING.LIB
+
+build-depends += \
+ pkg:/developer/macro/gnu-m4
+
+configure-options += --enable-cxx
+
+# http://gmplib.org/manual/ABI-and-ISA.html
+configure-options.32 += ABI=32
+
+name := gmp
+home := http://www.gnu.org/software/$(name)/
+version := 5.0.5
+archive := $(name)-$(version).tar.bz2
+download := http://ftp.gnu.org/gnu/$(name)/$(archive)
+checksum := \
+ md5:041487d25e9c230b0c42b106361055fe \
+ sha1:12a662456033e21aed3e318aef4177f4000afe3b \
+ sha256:1f588aaccc41bb9aed946f9fe38521c26d8b290d003c5df807f65690f2aadec9 \
+ size:2052144
diff --git a/gmp/gmp.p5m b/gmp/gmp.p5m
new file mode 100644
index 0000000..4b4c139
--- /dev/null
+++ b/gmp/gmp.p5m
@@ -0,0 +1,30 @@
+set name=pkg.fmri value=pkg:/library/gmp@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source_url value="$(download)"
+
+license $(license-file) license=$(license)
+
+dir path=usr
+dir path=usr/include
+dir path=usr/lib
+dir path=usr/lib/$(MACH64)
+dir path=usr/share
+dir path=usr/share/info
+file path=usr/include/gmp.h
+file path=usr/lib/$(MACH64)/libgmp.so.10.0.5
+file path=usr/lib/libgmp.so.10.0.5
+file path=usr/share/info/gmp.info
+file path=usr/share/info/gmp.info-1
+file path=usr/share/info/gmp.info-2
+link path=usr/lib/$(MACH64)/libgmp.so target=libgmp.so.10.0.5
+link path=usr/lib/$(MACH64)/libgmp.so.10 target=libgmp.so.10.0.5
+link path=usr/lib/libgmp.so target=libgmp.so.10.0.5
+link path=usr/lib/libgmp.so.10 target=libgmp.so.10.0.5
+
+# GMP 5.0 is upwardly source and binary compatible with 4.x,
+# and 3.x versions, except for applications that use
+# the semi-documented mpn_bdivmod function.
+link path=usr/lib/$(MACH64)/libgmp.so.3 target=libgmp.so.10
+link path=usr/lib/libgmp.so.3 target=libgmp.so.10
+
diff --git a/gmp/gmpxx.p5m b/gmp/gmpxx.p5m
new file mode 100644
index 0000000..d93a82b
--- /dev/null
+++ b/gmp/gmpxx.p5m
@@ -0,0 +1,20 @@
+set name=pkg.fmri value=pkg:/library/gmpxx@$(ips-version)
+set name=pkg.summary value="$(summary), C++ library"
+set name=info.upstream-url value="$(home)"
+set name=info.source_url value="$(download)"
+
+license $(license-file) license=$(license)
+
+depend fmri=pkg:/library/gmp@$(ips-version) type=incorporate
+
+dir path=usr
+dir path=usr/include
+dir path=usr/lib
+dir path=usr/lib/$(MACH64)
+file path=usr/include/gmpxx.h
+file path=usr/lib/$(MACH64)/libgmpxx.so.4.2.5
+file path=usr/lib/libgmpxx.so.4.2.5
+link path=usr/lib/$(MACH64)/libgmpxx.so target=libgmpxx.so.4.2.5
+link path=usr/lib/$(MACH64)/libgmpxx.so.4 target=libgmpxx.so.4.2.5
+link path=usr/lib/libgmpxx.so target=libgmpxx.so.4.2.5
+link path=usr/lib/libgmpxx.so.4 target=libgmpxx.so.4.2.5